Skip to content

Apple Update…

  • by

There has been a security vulnerability confirmed by Apple on iPhones 6 and newer, all iPads, and computers with Monterey operating systems. We recommend that you update your devices as soon as possible.

“Apple users have been advised to immediately update your iPhones, iPads and Macs to protect against a pair of security vulnerabilities that can allow attackers to take complete control of your devices. Anyone with an iPhone released since 2015, an iPad released since 2014 or a Mac running macOS Monterey can download the update by opening up the settings menu on your mobile device or by choosing “software update” on the “about this Mac” menu on your computer. ”

The list of devices affected by both vulnerabilities are:

  1. Macs running macOS Monterey
  2. iPhone 6s and later
  3. iPad Pro (all models), iPad Air 2 and later, iPad 5th generation and later, iPad mini 4 and later, and iPod touch (7th generation).

Frankenstein Computers has been taking care of our happy clients since 1999. We specialize in IT Support, Cyber Security, IT Service, IT Security MAC repair, PC Repair, Virus Removal, and much more. Give us a call for remote support or drop in to drop off.