Yet Another Flash Exploit

Adobe has released a new patch to address a new Adobe Flash Exploit that infects Office documents. If you must still use Adobe Flash (even having it installed on your system), please ensure to ALWAYS keep Adobe Flash up-to-date. This technology has been deprecated largely to the fact that it is so vulnerable to attacks. This new exploit came out on June 7th; therefore, please ensure that you do not have Adobe Flash Player 29.0.0.171 or earlier, if you do, make sure you update. If you have any issues updating or are unsure, please reach out to us to have one of our technicians install it on your system if necessary.

 

Not sure about your version? Check out this link to see which version is installed and if you need to update or if Adobe Flash has updated already:

http://get.adobe.com/flashplayer/about/

 

Once you’re up-to-date, you can also protect yourself by disabling macros in Microsoft Office. Give us a call if you’d like for us to help you make sure your PC is safe. Stay ahead of the curve and allow us to make sure your systems are up-to-date!

 

Frankenstein Computers has been taking care of our happy clients since 1999. We specialize in IT Support, IT Service, MAC repair, PC Repair, Virus Removal, and much more.  Give us a call for remote support or drop in to drop off.